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Two approaches to image editing 
When images are edited in Photoshop or any other editing program 
there are two general approaches: 

Direct or Destructive editing: In simple photo-editing programs, all 
changes are made directly to the image and those changes will become 
permanent when you save the image. The changes are permanent 
because editing (eg contrast adjustment) changes at least some of the 
pixels in the image. These changes cannot be reversed except in the 
special ways described in the next sub-section. Destructive editing is a bit 
like applying a tattoo to skin - once the tattoo is applied it is hard to 
change or remove and you can never get back to the original skin. 

Destructive editing is OK if you can be certain that each change you make 
produces exactly the result you want and if you can be sure that any later 
changes you make will not alter the effect of earlier changes. It is not 
often that you can have this level of certainty  when editing - so 
destructive editing is not recommended. 

Undoing direct edits. 
If there is some reason why you have to use destructive editing, there are 
several ways that you can “undo” edits in Photoshop: 

a. You can undo the last change you made by pressing Control+Z 
(Windows) or Command+Z (Mac). 

b. You can step backwards through several edits by pressing 
Control+Alt+Z (windows) or Command+Option+Z (Mac). 

c. You can remove all edits and get the image back to what it was 
when you opening it by selecting File>Revert from the menu. 

d. If you have made several edits you can go back to any one of them 
by selecting the relevant step of the editing process in the History 
panel. 

e. In the History panel you can take a “Snapshot” of the image after 
several edits, make more edits, take another Snapshot, and so on. 
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Then, if necessary you can come back to any one of those 
Snapshots by selecting it in the History panel. 

You cannot do any of the above after you have saved and closed the 
image file - when you re-open the file the “history” will have been lost. 

Non-destructive editing: A much better approach is to use non-
destructive editing that allows you to modified or reverse any of the 
editing, even if you save the file and then re-opened it. This approach to 
editing changes the appearance of the image without changing any of 
the pixels in the original image. 

Because there are many occasions when you will want to edit an image in 
stages or change your mind about an edit or produce several different 
versions of an image, non-destructive editing is recommended.  
There are various approaches to non-destructive editing, depending on 
what software you are using. It can be done in RAW converters such as 
LIghtroom or Adobe Camera Raw, or it can be done in programs such as 
Photoshop that support the use of layers. 

Layers 
Layers are one of the most powerful features of Photoshop (or any other 
program that supports layers) because they provide ways of editing 
images that are simply not possible without layers. Using layers to edit an 
image is a bit like adding make-up to a face. No matter how much make-
up you apply or what the face looks like with the make-up applied, the 
underlying face has not changed and you can always wash off the 
makeup and see the original face again. 

When you open an image in Photoshop it becomes the background 
layer. Other layers can be placed on top of this background to change 
the appearance of the image without altering anything in the background 
layer. You can think of these additional layers as being like sheets of 
acetate in a stack - the appearance of the overall image depends on what 
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you see when looking down through this stack. For example, if I open this 
image as the background layer: 

 

And place this image (transparent except for the bird) in a layer above it: 

The composite image (‘seen from above’) would be this: 
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The overall process can be represented as follows: 

Some of the advantages of creating the composite image in this way, 
rather than placing the bird directly into the original image are: 

a) The bird can be removed simply by deleting the top layer. 

b) The bird can be moved around or rotated in the top layer without 
altering anything in the bottom layer. 

c) The size of the bird can be changed without altering anything in the 
bottom layer. 

d) Enhancements such as sharpening or colour changes can be made to 
the bird without altering anything in the bottom layer. 

The process of combining images in this way is just one of the many 
applications of layers and utilises just one of many types of layers (image 
layers). 
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The layers panel 

The layers panel is the ‘control centre’ for layers in Photoshop. If it is not 
visible you can open it by selecting Windows>Layers from the menu or 
by pressing F7. 

When an image is opened in Photoshop the layers panel will initially look 
like this: 

By default, the layer name will be “Background” and it will be 
‘locked’ (which restricts what can be done to this layer).  

The preview thumbnail will be a miniature version of the image. 

The ‘eye’ icon allows yo to turn the visibility of the layer on and off. If you 
turn of the visibility of this background layer the screen will be blank. 
Later, when you add additional layers, the visibility of each layer can be 
independently turned off to temporarily remove whatever effect was 
created by that layer.  
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You can make adjustments (via the menu) that will alter this background 
layer - but this is NOT a good idea as it would be destructive editing and 
the whole idea of layers is to enable you to do non-destructive editing.  

Most of the things you will want to do with layers can be achieved from 
the layers palette, many of them with the layers panel icons or from the 
layers panel menu.  

Before starting to use the layers panel icons or menu items you need to 
know what type of layers can be created and what their general purposes 
are. The basic layer types are: 

a) Image layers (that contain at least some image pixels). 
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b) Fill layers that contain solid colours or patterns and which are initially 
opaque. 

c) Fill layers that contain gradients which may or may not be semi-
transparent. 

d) Empty layers that are used to hold image information later (such as 
when cloning). 

e) Text layers. 

f) Adjustment layers that contain ‘instructions’ for altering the image 
(such as brightness/contrast adjustments). 

Of the seven layer panel icons, two allow you to create new layers. One is 
for creating a new ‘empty’ layer and one is for creating fill layers (solid 
colours, gradients or patterns) or adjustment layers. These, plus the icon 
for creating layer masks are the three that you will use most frequently. 
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You can also create two types of new layer from the layer panel menu - 
either a new empty layer or a duplicate of the layer that is currently 
selected. 

New layers can also be created from the main Photoshop menu and 
again there are three options: 

Layer>New>Layer will create a new empty layer. 

Layer>New Fill Layer will allow you to create a layer with a solid 
colour, a gradient or a pattern. 

Layer>New Adjustment Layer will allow you to create one of 16 
different types of adjustment layer in Photoshop CC (earlier 
versions of Photoshop had fewer types of adjustment layer).  
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Fill layers 

The options for fill layers are: 

There are various uses for fill layers and these will be explored in another 
tutorial. The content of fill layers cannot be edited directly (as it can be for 
image layers), it is done through a dialogue. 

Adjustment layers 

Adjustment layers are the ‘heart’ of non-destructive editing in Photoshop. 
Adjustment layers do not ever contain image pixels, they just contain 
‘instructions’ that Photoshop uses to change the appearance of images. 
For example, a Brightness/Contrast adjustment layer would contain 
information about the brightness and contrast adjustments you have 
made using that layer. 

Adjustments that are made with adjustment layers are non-destructive 
because: 

(a) The adjustment layers do not change any of the pixel information 
in your image. 
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(b) You can remove the layer simply by dragging it to the trash can at 
the bottom of the layers panel. 

(c) You can change the adjustment by double clicking on the 
adjustment icon on the layer - the adjustment dialogue will re-open 
and you can make the change. 

(d) If you save the image as a PSD (Photoshop) or TIFF file the layers 
are preserved. Next time you open the image the layers are still 
there and you can make further adjustments to any layer if you 
want to. (Note: You cannot save layers in a JPEG file.) 

When you create an adjustment layer, it will effect all the layers below it 
(but none above it). You can restrict it to effecting just the layer 
immediately below it by creating a clipping mask. To do this, hold down 
the Alt key and click on the boundary between the two layers. 

The types of adjustment layer available in Photoshop CC are: 

Brightness/Contrast 
Levels 
Curves 
Exposure 
Vibrance 
Hue/Saturation 
Colour Balance 
Black and White 
Photo Filter 
Colour Mixer 
Colour Lookup 
Invert 
Posterise 
Threshold 
Gradient Map 
Selective Colour 
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The quickest way to create an adjustment layer is to select its icon from 
the Adjustments Panel: 

If this panel is not visible, open it from the menu: Windows>Adjustments. 

Example: 
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When you create an adjustment layer, a window opens to give you the 
controls that are specific to that type of adjustment. 

 

Copying layers 

Sometimes you will want to create duplicates of layers. There are four 
ways to copy a layer: 

1. From the main menu select Layer>Duplicate Layer. 

2. From the layers panel menu select Duplicate Layer. 

3. In the layers panel click on the layer and drag it to the New 
Layer icon at the bottom of the panel. 

4. Select the layer and press Ctrl-J (Windows) of Cmd-J (Mac). 
(Note: If you make a selection on an image and press Cmd-J it 
will create a new layer that contains just that selection. This 
only works on image and fill layers.) 
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Layer opacity 

 There are two other important layer options that can be selected in the 
layers panel - blend mode and opacity. 

 The opacity slider changes the transparency of the layer if it is an image - 
so reducing the opacity allows you to ‘see through’ an image, as in the 
following example: 
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When the opacity of the top layer is reduced to 50% we get this: 
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 If the opacity of an adjustment layer is reduced, the amount of influence 
the adjustment layer has on the layers below it is reduced as in this 
example: 

The original image could benefit from a boost in contrast, so a curves 
adjustment layer is added: 
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The effect of the curves adjustment layer is too strong, so the opacity of 
that layer is reduced to 50%. 

Some useful techniques with layers 

1. To delete a layer - select the layer and press ‘delete’ or select the 
layer and drag it into the trash can at the bottom of the layers panel. 

2. To move a layer up or down in the stack of layers just select it and 
drag it to the desired opposition. 

3. To flatten all the layers in an image (and keep the overall appearance 
of the image) select “Flatten image” from the menu in the layers 
panel. Generally, flattening layers is not a good idea because you 
cannot undo it later. 

4. To merge all the layers in an image without flattening it (so that you 
still have all the separate layers) - select the top layer in the stack and 
press Ctrl+Shift+Alt+E (Windows) of Cmd+Option+Shift+E (Mac). The 
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new merged layer will appear above the previously selected top layer. 
This process is called “Stamp Visible” because if some of the layers 
are turned off (not visible) when you do it, the merged layer will not 
contain any information from those turned off layers. 

5. To copy a layer from one image to another - drag the layer from the 
layers panel in one document and drop it on to the other document. If 
you hold down the shift key while you drag, the layer will be centred 
on the second document. You will normally only do this if the two 
images have the same pixel dimensions. 

6. To fill a layer with the foreground colour press Alt+Backspace 
(Windows) or Option+Delete (Mac). 

7. To fill a layer with the background colour press Control+Backspace 
(Windows) of Command+Backspace (Mac). These last two processes 
work for selections as well as for layers but only on image or fill layers. 
If you do it on an adjustment layer it fills the layer mask with black or 
white. 

8. When you save a file in the PSD (Photoshop) format or the TIFF 
format the layers are preserved (they will be there when you open the 
file next time). If you save the file as a JPEG, Photoshop will flatten the 
file (merge the layers) before saving it. When you open it next time 
the layers will not be there. If you need to save a JPG version of a file 
it is usually best to first save the PSD file with layers, then save the JPG 
file. 

9. To select a layer (rather than selecting all layers in the image), hold 
down the Ctrl key (Windows) of Cmd Key (Mac) and click on the layer 
thumbnail in the layers panel. 

10. To rotate a layer, select it (using the technique above) and then 
choose Edit>Transform or Edit>Free Transform from the main menu. 
When the rotation is made, press Enter (Return on Mac) to confirm it 
and then Ctrl-D (Cmd-D) to deselect the layer. 
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Blend modes 
The blend mode of each layer controls the way that layer interacts with 
the layers below. Unless you change it, the layer blend mode will be 
‘normal’. This simply means that the layer will effect the layers below in 
the way that you would expect.  

The other blend modes use various mathematical functions to determine 
how the layer being blended interacts with the layers below it. They are 
grouped into the following categories: 

Blend Modes that darken some/all pixels: 

Darken 

Multiply 

Colour burn 

Linear burn 

Darker colour 

Blend Modes that lighten some/all pixels: 

Lighten 

Screen 
Colour dodge 

Linear dodge 

Lighter colour 

Blend Modes that alter the contrast in the image: 

Overlay 

Soft light 

Hard light 

Vivid light 

Linear light 

Pin light 
Hard mix 
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Blend Modes based on colour information: 

Hue 

Saturation 

Colour 
Luminosity 

In each group, the blend mode shown in blue is the one you will probably 
find most useful. These and other modes are described in detail in 
another tutorial. For now, here are just a few points about blend modes: 

1. The blending mode of the background layer cannot be changed. 

2. The blending mode of all other image, fill or adjustment layers can be 
changed. 

3. The result of changing the blending mode of a layer will depend on: 

(a) The blend mode selected. 

(b) The type/content of the layers being blended. 

(c) The opacity of the blending layer. 

Following are just a couple of simple examples of what can be achieved 
with blending modes: 
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Blending an image with itself to give more structure and depth of colour: 
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Blending two different images: 
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LAYER MASKS 
To “mask” something means to cover it. So layer masks are used to cover 
part or all of the content of image layers or the effect of adjustment 
layers. 

Layer masks have to be greyscale (they cannot contain any colour 
information) so they can contain white, black and any shades of grey. The 
effect is this: 

• WHITE – on an image layer, this part of the mask allows the 
corresponding part of the image to be visible. On an adjustment 
layer it allows the adjustment to be applied to the corresponding  
part of the image. 

• BLACK – on an image layer, this part of the mask will hide the 
corresponding part of the image (making it transparent). On  an 
adjustment layer it prevents the adjustment being applied to the 
corresponding  part of the image. 

• Shades of GREY – on an image layer, this part of the image will 
become partially transparent.  On  an adjustment layer, the effect of 
the adjustment will be reduced on the corresponding  part of the 
image (depending on the density of the shade of grey). 

When a layer mask is applied, it shows as a small icon on the appropriate 
layer in the layers panel: 
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If you hold down the Alt key and click on the layer mask icon the mask will 
appear full size in place of the image, and you can then edit it just as you 
would an image. To close the layer mask, Alt-click on its icon again. 

In the above example, the mask was applied to the background layer so 
the effect on the image would be this: 

The strip down the left hand side of the image has been covered by the 
black area of the layer mask. 

If a colour fill layer was placed below the background layer and this layer 
mask applied the result would be: 
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The left hand side of the image is fully masked (covered) to reveal the 
coloured layer beneath and the right hand side is made partially 
transparent by the mid-grey strip on the mask. 

When you create an ADJUSTMENT layer, a white layer mask is created 
automatically. For example: 

If nothing is done to this mask (no black or grey added to it) the 
adjustment will have full effect. If black or grey is added to the mask then 
the effect of the 
adjustment will be reduced 
in those areas according to 
the density of the grey 
toning.  For example, if the 
previous black/white/grey 
mask was applied to a 
brightness/contrast layer 
adjusted to reduce the 
brightness of the previous 
elephant image the result 
would be this: 
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You can see that no change has occurred on the left of the image where 
the mask is black. The full effect of the brightness reduction has occurred 
where the mask was white (in the centre part of the image), and there has 
been a partial reduction in brightness where the mask was grey. 

If you create a fill layer (solid colour, gradient or pattern) Photoshop will 
automatically create a white layer 
mask. 

If you add an empty layer or an 
image layer, no mask will be 
created. You can manually add a 
mask to any layer by clicking on 
the layer mask icon at the bottom 
of the layers panel: 
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Complex layer masks can be used to restrict adjustments to specific parts 
of an image, as in the following example. 
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By creating a layer mask based on the orange tones in the original image 
the hue/saturation adjustments can be restricted to the ‘orange’ areas: 
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Layer masks can be used to combine two images, as in the following 
example. 
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How to place two images into layers in a single file 

If you want to combine images in the way I have show above you need to 
place the two original images (the beach scene and the bird) as layers in 
the same image file. The procedure is as follows: 

1. Open the first image - the one that will be the background image (the 
beach scene in this example). 

2. Open the second image (the bird in this example). 

3. Select all or part of the second image - the part that you want to copy. 
This does not have to be a precise selection as you can apply layer 
masks later to refine it. 

4. Copy this section (or the whole image). 

5. Switch to the first image. 

6. Paste the copied image - it will become a new layer on top of the first 
image. 

7. If necessary, use the Move tool to reposition the second image. You 
might find it useful to reduce the opacity of this second image layer to 
help you re-position it. 

8. When you are satisfied with the position of the second image you 
might need to create a mask on that layer to remove any unwanted 
elements. 

Some tips for working with layer masks 

Layer masks can be moved from one layer to another by simply clicking 
on the layer mask icon and dragging it to the required layer. 

Layer masks can be copied from one layer to another by Alt-clicking on 
the layer mask icon and dragging it to the required layer. 
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Layer masks can be inverted (whites changed to black and blacks 
changed to white) by selecting the layer mask (just click on its icon) then 
pressing Ctrl-I (for windows) or Cmd-I (for Mac). 

Note: When a layer mask is created, it also appears as an alpha channel 
(more about channels later). If this alpha channel is duplicated, it will be 
saved with the image even if the image layers are flattened before 
saving.  

If you make a selection and then add an adjustment layer (perhaps by 
clicking on the relevant icon on the adjustments panel) the adjustment 
layer created will automatically have a layer masks with a white area that 
corresponds to the selection.   

The following example shows how a layer mask can be copied and 
inverted to allow for different types of adjustments on two areas of an 
image. 

In the original image the lions are obviously in shade and the background 
is in bright sunlight. To improve the image it is necessary to lighten the 
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main subject and darken the background. The process used was as 
follows: 

1. Duplicate the background layer. 

2. Open the duplicated layer in Adobe Camera Raw by using the 
Camera Raw filter in Photoshop. Make adjustments to improve the 
appearance of the lions without being concerned about the 
background. Return the image to Photoshop. 

3. Create a layer mask based on the lions.  

The result was: 
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The next step was to add a brightness/contrast layer and adjust it to give 
the desired effect on the background. So that these adjustments did not 
effect the lions, the previously created layer mask was copied to the 
brightness/contrast layer and inverted to give the final result. 
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CHANNELS 
Channels are “storage baskets” that hold information that Photoshop uses 
to construct images.  

RGB images (the colour mode in which we normally work in Photoshop) 
consist initially of three channels: red, green and blue.  Each channel 
contains information about the variations in intensity of the relevant 
colour across the image. Each channel is a grayscale image in which light 
areas represent intense colour and dark areas represent lack of colour. 

Consider this example:  

In Photoshop, the image is constructed 
from information about the red, green and 
blue components of the colour in each 
pixel. To see how much of each of these 
colours is used to create the image we can 
look in the Channels Panel where we 
would see this: 
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Saving channels as layer masks 
There are many ways in which you can use the information in the RGB 
channels, and one of the most useful is to use it to generate layer masks. 
The process is simple: 

• Open the Channels panel and decide which channel you want to 
use. 

• Ctrl-click (Windows) or Cmd-click (Mac) on the required channel. 
This generates a selection based on the grayscale information in the 
selected channel. It may not look like a very clear or neat selection 
but don’t be concerned about that. 

• Select the layer to which you want to apply the mask and click on 
the “Add layer mask” icon. This applies the mask to the layer. (Note: 
If the layer already has a mask, perhaps created automatically on an 
adjustment layer, you will have to delete this mask before applying 
the mask that is generated from the channel.) 

Once you have generated a layer mask in this way, you can use it or 
modify it in the same way that you would any other mask. For example, 
you could open the mask (Alt-Click on the mask icon) and apply a Levels 
adjustment to it to increase the contrast between the light and dark areas 
of the mask. You might also want to paint on the mask (with black, white 
of grey) to make it more useful. 

The general principle is this: If you want to use the mask to provide very 
subtle changes to your image you will probably want to keep the 
greyscale information that came from the channel. The shades of grey in 
the mask will provide gradual changes between the light and dark areas 
and thus blend the changes provided by the light and dark areas of the 
mask. . If you want to use the mask to make very definite differences 
between parts of an image you will probably want to modify the original 
mask with adjustments or painting.  
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The following example shows how channel-generated masks can be 
produced, modified and used on the flower image shown earlier. 

In order to achieve this result is was necessary to use a clipping mask. 
This simply means that the adjustment layer was “clipped” to the layer 
below if so that the adjustment affected that layer but not all layers.  

As is usually the case in Photoshop, this result could have been achieved 
with a different approach.  The mask could have been applied directly to 
the levels adjustment layer. 

Saving selections 
When you create a selection (no matter how you do it) you can save that 
selection as an alpha channel by simply selecting Select>Save Selection 
from the main menu. 

Saving layer masks 
Sometimes it is useful to be able to save layer masks so that you can use 
them multiple times. The simplest way to do this is to save the masks as 
alpha channels. The process is simple because each time you create a 
layer mask it automatically appears as an alpha channel in the Channels 
panel. To save it, all you have to do is right click on the channel containing 
the mask and select “Duplicate Channel”.  

Turning a Channel into a Layer 
Sometimes it is useful to be able to turn a channel into a layer rather than 
into a layer mask. The process is as follows: 

• Open the Channels panel and click on the icon of the channel you 
want to use. The “eye” symbol should stay on for this channel and 
go off for all the other channels. You should then see a greyscale 
image of the selected channel. 
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• Press Ctrl-A (Windows) or Cmd-A (Mac) to select all this image. 

• Press Ctrl-C or Cmd-C to copy the image. 

• Select the RBG channel in the channels panel (click on its icon) and 
you should see the full colour image back again. 

• In the Layers panel select the layer above which you want the new 
layer to appear. 

• Press Ctrl-V (or Cmd-V) to paste the new layer. It should appear in 
the layers panel and be visible as the top layer of your image. 

SUMMARY 
Using the information in these notes, it is possible to do the following: 

Convert a selection to a layer mask. 

Convert a selection to a channel. 

Convert a layer mask to a channel. 

Convert a channel to a selection. 

Convert a channel to a layer. 

If you master each of these techniques it will open a new world of image 
editing possibilities.  

If you have any suggestions for improving these notes please email me at 
roykillen@mac.com 
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